OS Linux6.2 で rpm コマンドを使用した時にエラーになる

# rpm -Uvh bind-8.2.2_P7-1.i386.rpm をすると以下のエラーが出る

メジャー番号<=3のパッケージのみこのバージョンのRPMはサポートされています
エラー:bind-8.2.2_P7-1.i386.rpm cannot be installed

以上のメッセージが出てパッケージをインストールできないので
教えてください

このQ&Aに関連する最新のQ&A

A 回答 (2件)

bind-8.2.2_P7←これが7なのが気になるのですが


RedHat7J用のRPMなんでしょうか?

redhat系だと 6.xと7以上でRPMのバージョンがかわり
6.x系のRPMでは新しいrpmがほどけなかった気がします。

先に、rpmのバージョンを最新の物に上げてみてください。
    • good
    • 0
この回答へのお礼

大変ありがとうございました。
RPMのバージョンが違うのですね。
bind-8.2.3-0.6.x.i386.rpmその他をダウンロードしてやってみます

お礼日時:2001/02/01 08:29

確かに....同じメッセージが.



解決してしまったのかもしれませんが.

h_hikita さんが書かれているように、rpm の
バージョンを上げればインストールできると思います.

==

bind-8.2.2-P7 もセキュリティ上
好ましくないので、bind-8.2.3 をインストール
することをお薦めします.

参考URLに、RedHat6.2 用の RPM も置いてあります.

参考URL:http://www.redhat.com/support/errata/RHSA-2001-0 …
    • good
    • 0
この回答へのお礼

大変ありがとうございました。
RPMのバージョンが違うのですね。
bind-8.2.3-0.6.x.i386.rpmその他をダウンロードしてやってみます

お礼日時:2001/02/01 08:31

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aと関連する良く見られている質問

Q起動時DRIVER_IRQL_NOT_LESS_OREQUAL(Smb_driver_sys)

先日ウインドウズ7から10にアップデートした時から起動時ブルーバックでこのメッセージが出るようになりました
対処法がわからず困っています。メッセージをなくす方法教えてください、よろしくお願いします。

Aベストアンサー

OSは違うかもしれませんが、同様のエラーメッセージに対して先日回答しています。
かなり残念な内容ですが、ご参考になれば。
https://oshiete.goo.ne.jp/qa/9067332.html

QRPMパッケージのアップグレードについて

APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、
現在下記の様な状態で悩んでいます。

# rpm -Fvh apache*.rpm
でアップグレードしようとすると、

エラー:依存性の欠如
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

というエラーが出ます。

次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、
以下のコマンドを入力しました。

# rpm -Fvh apache-*.rpm mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3
.i386.rpm mod_put-1.3-2.i386.rpm

そしたら、またしても

エラー: 依存性の欠如:
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

と表示されてしまいました。

インストールされているか、rpm -q で確認すると、
インストールされていません と返ってきました。

じゃあ、インストールしよう、と思って

#rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm mod_throttle-3.1.2-3.i386.rpm mod_put-1.3
-2.i386.rpm

と入力したら

エラー: 依存性の欠如:
apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します
apache < 1.3.22-1 mod_throttle-3.1.2-3 と競合します
apache < 1.3.22-1 mod_put-1.3-2 と競合します

と、返ってきました。


一体、どのようにしたら無事アップグレードできるのでしょうか?
それとも、現バージョンのAPACHEを削除してから新バージョンのインストールを
するしかないのでしょうか?


使用OS:Redhat Linux 7.1J

APACHEをRPMパッケージの最新版(apache-1.3.22-5.7.1)にアップグレードしたいのですが、
現在下記の様な状態で悩んでいます。

# rpm -Fvh apache*.rpm
でアップグレードしようとすると、

エラー:依存性の欠如
mod_bandwidthは apache-1.3.22-5.7.1 に必要とされています
mod_putは apache-1.3.22-5.7.1 に必要とされています
mod_throttleは apache-1.3.22-5.7.1 に必要とされています

というエラーが出ます。

次に、依存性の欠如で指摘されたファイルも一緒にアップグレードしようと、
以下の...続きを読む

Aベストアンサー

apacheのパッケージと、mod_bandwidthなどのモジュール類とを
一緒にインストールするのが(たぶん)正解だろうと思いますが、
エラーが出るってわけですね。
でも、それは、rpmのオプションがいけないんではないでしょうか?

rpm -Uvh

でリトライしてみてください。

rpm -Fvh は、「現在インストールされている」パッケージを
アップグレードしますが、mod_bandwidth等は、
現在インストールされていないわけですよね?
だからダメなんだろうと思いますよ。

QS-Jog Rpmパッケージ

いつもお世話になります

sjog-0.6-2.i586.rpmをインストール時に下記エラーとなりました。
Failed dependencies:
libgtk+1.2 >= is needed by sjog-0.6.2

gtk+-1.2が必要かなと思いgtk+-1.2.10-25.i386.rpmをインストールし
再度sjog-0.6-2.i586.rpmのインストールを試みるとまた同じエラーとなります。

これは何か別の設定やインストールしないといけないRPM等
あるのでしょうか?
超初心者ですがよろしくお願いします。

環境:
vaio Z505GR/K RedHatLinux9

Aベストアンサー

エラーメッセージは正確に

libgtk+1.2 >= 1.2 is needed by ....

ですね.

sjog のSPECには確かに上記パッケージへの依存関係が設定されていますが,RedHatのlibgtk+ は,単に gtk+ というパッケージ名なので,依存関係を壊さずにそのRPMをインストールすることはできません.

ソースから,おきまりの configure, make, make install の手順で簡単にインストールできると思いますが,それではダメなんでしょうか?

QCコンパイラ(RPMパッケージ)のインストール方法を教えてください

リナックスを最小インストールにしたから、だと思うのですが
僕のマシンにCコンパイラが入っていないようです。
これが無いとソースを拾ってきてもインストール出来ないんですよね。
リナックスのCDの中にgcc-3.2-7.i386.rpmというのを発見しました。
gccというのを調べてみますと何かコンパイラのパックみたいなもののようで、これをインストールしようと思ったのですが
# rpm -ihv /mnt/cdrom/RedHat/RPMS/gcc-3.2-7.i386.rpm
警告: /mnt/cdrom/RedHat/RPMS/gcc-3.2-7.i386.rpm: V3 DSA signature: NOKEY, key ID
db42a60e
エラー: Failed dependencies:
cpp = 3.2-7 is needed by gcc-3.2-7
binutils >= 2.12.90.0.7-1 is needed by gcc-3.2-7
glibc-devel >= 2.2.90-12 is needed by gcc-3.2-7
#
と何やら訳の分からん横文字が、ずらずらと出てきてインストール出来ませんでした。
どなたか、やり方を詳しく教えてくれませんか。
Cコンパイラをインストールするには、このgccってヤツでいいのですか、それとも他のrpmがあるのですか。

リナックスを最小インストールにしたから、だと思うのですが
僕のマシンにCコンパイラが入っていないようです。
これが無いとソースを拾ってきてもインストール出来ないんですよね。
リナックスのCDの中にgcc-3.2-7.i386.rpmというのを発見しました。
gccというのを調べてみますと何かコンパイラのパックみたいなもののようで、これをインストールしようと思ったのですが
# rpm -ihv /mnt/cdrom/RedHat/RPMS/gcc-3.2-7.i386.rpm
警告: /mnt/cdrom/RedHat/RPMS/gcc-3.2-7.i386.rpm: V3 DSA signature: NOKEY,...続きを読む

Aベストアンサー

>>cpp = 3.2-7 is needed by gcc-3.2-7
これはcppのインストールにgccが必要ですという意味です。メッセージ類は中学英語で読める英文が殆どですから苦手意識を持たず読むようにしてください。

コンパイラ類は依存関係があり他にもライブラリなどが必要になりますので初回インストール時にイントールしておくべきです。
もし面倒でなければインストーラCDからアップデートで開発環境のパッケージを追加する(念のため必要なデータのバックアップはとっておく)のがよいかと思います。もしくはいっそのことクリーンインストール。
もう一つの方法はCD-ROMのRPMSディレクトリから
rpm -Uvih *.rpm とコマンドを打ち全てのrpmパッケージをインストールする方法です。
しかし大量にHDDを消費する可能性がありますしマシンによってはイントールをやり直した方が早いかも…。とりあえず最初の方法が無難だと思います。

Qjavaws-1_2_0_01-linux-i586-i.zip

/usr/java/j2re1.4.1_01のなかに
javaws-1_2_0_01-linux-i586-i.zip
というものがありますがこれはいったいなんなのでしょうか?
ひらいてみるといろいろなファイルがみえます。
そのなかにinstall.shというものがありますがこれを
インストールするとどうなるのでしょうか?
インストールしてみようかとおもったのですが
インストールの方法がわかりません。
よろしくおねがいします。

Aベストアンサー

Java Web Startという機能です。
詳しくは下記URLを参考にしてください。

javaws-1_2_0_01-linux-i586-i.zipについて一番下に載っています
http://java.sun.com/j2se/1.4.1/ja/install-linux.html

Java Web Startについて
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/jws/index.html
http://java.sun.com/products/javawebstart/ja/index_ja.html
http://www.utj.co.jp/XML/dev/java/dxjava_3.html


人気Q&Aランキング

おすすめ情報