* 困っています

こんにちは。基本的な質問ですみません。

CentOS5.2でWEB・FTPサーバーを構築して
光回線(Bフレッツベーシック・ASAHIネット固定IP)を引きました。
すると以下の現象が発生しました。

サーバーのグローバルIPに別の場所からpingを打つと
応答がない時があるのですが、
何度か繰り返すとそのうち応答がくるようになります。
しかししばらくリクエストを送らないで置くと、またpingに応答がなくなるのです。

ルーターの設定としては、VLANを2つ作り、WAN側からのリクエストは
全てLAN側のサーバーIP(eth0)へNAT変換しています。
パケットフィルタリングは特に行ってません。
サーバーは前述のサーバーリクエスト用(eth0)と管理用(eth1)に
ネットワークポートを2つ持っています。


        WAN
         |
  [===ルータ(1812J)===]
[VLAN1]     [===VLAN2=====]
 |         |       |
 |         |       |
 eth0       eth1      eth0
[WEB・FTPサーバー]    [他のパソコン]

サーバーのログにネットワークダウン等のエラーが出てないのと、
同じLAN内の他のパソコンから該当サーバーの管理用LANポートへは
問題なくPingが通ること、プロバイダ・回線業者の障害アナウンスが無いこと、
pingを打った場所から他のサーバーへの接続では
そのような現象が出ないことから
ルーターが怪しいと考えているのですが、それを確認する為の
調査の仕方が分かりません。

初心者の為どのログにどのような情報があるのか、
まずは何をとっかかりに見ればいいのかが良くわかってない状況です。
(テストサーバーなので多少の無茶はできるのですが、
以前debug allをして画面が止まらなくなった時は冷や汗をかきました…)

1812Jもしくは他のCISCOルータを原因と見て障害調査を始める場合、
皆様でしたらまずどこから手をつけるのかを教えて下さい。

また、今回のケースに当てはまらなくても結構ですので、
CISCOルータで調査をする場合のセオリーのようなものがあれば
お聞かせ下さると幸いです。

宜しくお願い致します。

このQ&Aに関連する最新のQ&A

A 回答 (1件)

コンフィグ見てみないと何も言えない、安~いAsahiの回線だから何かコストなりの特性があるのかもしれない、まるでINSのキープアライブの設定入れ忘れてセッションが切れてる時のような報告だけど、結局の所情報不足でなんも言えないです。



「pingを打った場所から他のサーバへの接続ではそんな現象が出ない」
この「他のサーバ」ってなんのことですか?「他のPC」なら図でわかるんですが。
とりあえず1812のコンフィグを見せれる部分見せてもらえます?

それとVLAN1とVLAN2のeth0についている機器を入れ替えて同じチェックをしてみて下さい。それでサーバのpingのレスポンスがおかしければ悪いのはルータじゃなくてサーバでしょ。

この回答への補足

ご回答ありがとうございます。
文章が分かりにくくて申し訳ありませんでした。
「pingを打った場所」というのが、冒頭にある今回の異常を感知した場所のことで、
「他のサーバー」というのは、単に接続確認をする為だけの全く別の場所にあるサーバーになります。
問題を切り分けるにあたり、感知した異常が今回問題になっているサーバーのみに発生しており、
異常を確認した場所のローカルの問題では無いことを示したかったのです。

また、上記の質問で示した図は構成を簡略化したもので、
実際は以下のようにグローバルを2本差ししており、
それぞれ異なるセグメントにNAT変換しております。
VLANトランクの設定はありません。
(わかりにくくて申し訳ありません。)

 WAN              WAN
  |                |
 FE1               FE0
 Dialer2            Dialer1
[=====ルータ(1812J)======]
[VLAN601]    [======VLAN401=====]
(192.168.6.1)       (192.168.4.1)
 FE8        FE3        FE2
 |         |          |
 |         |          |
 eth0       eth1         eth0
(192.168.6.13) (192.168.4.13)  (192.168.4.100)
 [WEB・FTPサーバー]     [他のパソコン]

今回問題になっているのはFE1側→FE8のpingです。
またWAN回線は、FE0がフレッツ光プレミアム、
FE1がBフレッツベーシック、プロバイダはどちらも
ASAHIネットです。
その上で、コンフィグの抜粋は以下のようになります。

補足日時:2009/05/20 10:33
    • good
    • 0
この回答へのお礼

コンフィグを貼るスペースが無くて、友人に頼んで
貼ってもらったら複数アカウント使用ということで
アカウントを凍結されておりました・・・
申し訳ありませんでした。

また上記の現象ですが、ルーターを再起動したら消えました。
キャッシュか何かが悪さをしてたんでしょうか・・・
(このときstartup-configは障害発生時のrunning-configと同一です)

ともあれご回答いただきありがとうございました。

お礼日時:2009/06/04 11:39

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング