最新閲覧日:

【以前、「コンピューター&インターネット > OS > WindowsXP」 のカテゴリで問い合わせたのですが、問題解決しないのでカテゴリを変え、再度質問させてもらいます。よろしくお願いいたします。】

MIDI音源Roland SC-8820 をWin XP Home でUSB接続使用ができず困っております。以前はWin98でUSB接続で使用できていたのですが、WinXPをクリーンインストールした後、ローランド社の http://www.roland.co.jp/top.html をよく読み音源をインストールしようとしているのですが、USBケーブルを接続しても、「新しいハードウエアを検出しました」というメッセージが出ず、インストールができません。USBケーブルを接続してもSC-8820本体前面のPowerランプ、USBランプ、ともに点灯しません。パソコンのUSPポートが正常でないのか?と思いましたが、デバイスマネージャには

USB(Universal Sirial Bus)コントローラ
├USBルートハブ
├USBルートハブ
├VIR Rev 5またはそれ以降のUSBユニバーサルホストコントローラ
└VIR Rev 5またはそれ以降のUSBユニバーサルホストコントローラ

と表示されていて、「!」や「?」マークもないので、USBは正常と思われます。 念のため上記4つを削除し、再起動してUSBを再インストールしてみましたが、現象変わらずです。

不足の事項があれば指摘してください。よろしくお願いいたします。

このQ&Aに関連する最新のQ&A

A 回答 (5件)

>「カタログにUSBの注意書きが沢山」とありますが、そのカタログはWEBでも見ることができますか?それとも紙のカタログを見てるのですか?おしえていただけないでしょうか。

宜しくお願いいたします。

紙のカタログです。
パソコンのUSB端子への電源供給状態によってはバス電源方式で動作しない場合がありますとか、
次のUSBホストコントローラー搭載のパソコンでは正常に動作しないケースが確認されていますとか、
以下の機種では不具合が発見されており、ご使用になれませんとか、
です。

参考URLの<USB関連情報>に、同様のことがかかれているようです。
ただ、98での稼動実績があるわけですから、やはりドライバがあやしいのでは。

それにRolandはYAMAHAに比べると、ドライバ作成技術は劣っているように思えますし(^^;
USB MIDI I/FのUM-1とかでもなかなか2000用のドライバが出なかったですし。

参考URL:http://www.roland.co.jp/products/dtm/SC-8820.html

この回答への補足

カタログの件、教えていただきありがとうございました。確かに、イヤな事が沢山かいてありますね。(^^ゞ

昨日、例のTAのHPを見に行ったら、「XPでUSB接続で使う場合Win2000用ドライバでOK」と書いてあったので、早速TAをUSBに接続してみたのですが、一応機器が接続されたことは認識したのですが「不明なデバイス」として認識されてしまいTA用のドライバをインストールする事ができず、結局このTAもUSB接続では使用できませんでした。現在TAはシリアル接続で使用しています。

この様な状況から、接続機器本体、または接続機器のドライバに問題があるのでなく、PC側のUSBポート自信にに何らかの問題があるような気がしてきました。

ところで、本日USBハブ(ACアダプタ付)を入手したので、今夜これを接続して試して見ようと思います。うまくいくか解りませんが、結果をまたご報告いたします。

補足日時:2001/12/14 08:36
    • good
    • 0
この回答へのお礼

返事が遅れてすいません。
USBハブ(ACアダプタ付)を接続してやってみましたが、症状変わらずです。
どうやっても私のマシンにXPを入れるとUSBポートが使えないようです。

仕方ないので、WIN98に戻そうかと考えてます。せっかくXP買ったのに悔しい...

それともUSB増設ボードを購入してみようかなぁとも思ってますが、なんだかトホホの道まっしぐらのような気がしてきました。 (^^ゞ

お礼日時:2001/12/17 10:04

98では使えていたとのことですが、


その時と同じマシン,同じ接続でしょうか?

とすると、XP用のUSBのMIDIドライバか、USBのドライバそのものの問題かも知れませんね.
多分,ACアダプタは付属していると思いますので,
それで試してみては?

しかし,カタログ見ているとUSBに関しては注意書きが沢山(^^;

この回答への補足

いろいろとご指摘ありがとうございます。
Win98で使っていた自作機と全く同じマシン、同じ接続です。HDDをフォーマットし、XPをクリーンインストールしました。

98の時もACアダプタは使用せずUSB経由の電源で作動していました。今回念のためSC-8820付属のACアダプタを接続したところPowerランプは点灯しましたが、USBランプが点灯せず相変わらずSC-8820を検出してくれません。

おっしゃる通り、USBドライバそのものの問題なのでしょうかねぇ。何か別のUSB機器を繋いでみて、それが動くのであればSC-8820のドライバの問題ってことになるのでしょうか?今手元にあるUSB機器といえばISDN用のTAだけなんですけど、このTAのXP用ドライバが公開されてないのです。だから試せない...

「カタログにUSBの注意書きが沢山」とありますが、そのカタログはWEBでも見ることができますか?それとも紙のカタログを見てるのですか?おしえていただけないでしょうか。宜しくお願いいたします。

補足日時:2001/12/13 10:58
    • good
    • 0

うーん、電源ランプが点灯しないのが気にかかりますね。


SC-8820って、電源はUSB経由での供給でしたっけ?
別途ACアダプタとかは付属していませんでした?

USB経由での供給の場合、それ以外に電源を使用するUSBデバイス接続されていませんか?
あるいは、USBハブに対して電源は供給されていますか?

USB経由では最大500mAの電流しか供給できないので、一つのハブに複数のデバイスが繋がっていたりすると、電源が取れない場合があります。

もしこの場合でしたら、ハブに電源を供給するとか、SC-8820にACアダプタを装着するとかで解決できるかもしれません。

この回答への補足

お返事ありがとうございます。
SC-8820の電源はUSB経由供給です。しかし、別途ACアダプタも付属していました。

Win98の時と同じマシンでOSを入れ替え、接続は98の時もUSB供給で作動していてACアダプタは使用していませんでした。

USB接続しているのはSC-8820のみです。USBハブは使っていません。つまりPC本体のUSB電源のみで供給しています。

念のため、SC-8820付属のACアダプタを接続したところ、Powerランプは点灯しましたが、USBランプは点灯せず、相変わらず、「新しいハードウエアを検出しました」というメッセージが出ません。

補足日時:2001/12/13 10:33
    • good
    • 0

念のため確認しますが、XP対応のドライバをインストールしていますよね?



SC-8820 USBドライバVer.1.3
for Windows XP / Windows 2000
2001.12.07更新となっています。

http://www.roland.co.jp/lib/download/SC8820USB_W …

また、XP用のインストール手順に従っていますか。
http://www.roland.co.jp/cs/WinXP_DrvInstall.html

参考URL:http://www.roland.co.jp/cs/WinXP.html

この回答への補足

> 念のため確認しますが、XP対応のドライバをインストールしていますよね?
> SC-8820 USBドライバVer.1.3
> for Windows XP / Windows 2000
> 2001.12.07更新となっています。
SC-8820 USBドライバVer.1.3 は「2001.11.16」版をダウンロードしました。
これから、念のため最新版をDLしてみようと思いますが、多分変わりないのでは。。。?


> また、XP用のインストール手順に従っていますか。
> http://www.roland.co.jp/cs/WinXP_DrvInstall.html
はい、従ってます。
この手順の5-5のところで、電源を入れると
《※ Windows の右下隅に「新しいハードウェアが見つかりました」と表示されますので、しばらくお待ちください。》
とありますが、「新しいハードウェアが見つかりました」が表示されないのです。
また、SC-8820本体前面のPowerランプ、USBランプ、ともに点灯しません。

困った、困った。 (T_T)

補足日時:2001/12/12 12:49
    • good
    • 0

「USBルートハブ」及び「VIR Rev 5またはそれ以降のUSBユニバーサルホストコントローラ」を4つとも削除して、再起動してみたらどうでしょうか。



多分これで、USBデバイスが再インストールされると思いますよ。

この回答への補足

4つとも削除して、再起動しました。USBデバイスが再インストールされましたが、相変わらずSC-8820を認識してくれません。(T_T)

補足日時:2001/12/12 04:24
    • good
    • 0

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


人気Q&Aランキング

おすすめ情報