人に聞けない痔の悩み、これでスッキリ >>

Fedora linuxでpostfixをインストールしようと

「yum -y install postfix」ってコマンドを入れると

Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
retrygrab() failed for:
http://fedora.redhat.com/releases/fedora-core-1/ …
Executing failover method
failover: out of servers to try
Error getting file http://fedora.redhat.com/releases/fedora-core-1/ …
r.info
[Errno 7] HTTP Error (CannotSendRequest):

ってメッセージが返ってきます。

/etc/yum.conf は

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=1

[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=http://fedora.redhat.com/releases/fedora-core-$r …

[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://fedora.redhat.com/updates/released/fedora …

#[updates-testing]
#name=Fedora Core $releasever - $basearch - Unreleased Updates
#baseurl=http://fedora.redhat.com/updates/testing/fedora- …

てなっています。接続先のURLが変わったのでしょうか?
ご教授いただけますか?
以上、何卒よろしくお願いいたします。

このQ&Aに関連する最新のQ&A

A 回答 (2件)

こんばんは。



ネットワークの設定に問題は無いですか?
ファイアウォール(iptables、ルータ等)に問題は無いですか?
DNSで名前解決(resolv.conf)は問題ないですか?

こちらのFedoraCore1で試しに、LANケーブルを抜いたり、DNSの設定を無効にした状態で、
yum install を実行したら、あなたとそっくり同じエラーメッセージが
表示されます。


(1) LANケーブルを抜いて実行してみた。

[root@pc123 root]# yum install postfix
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
retrygrab() failed for:
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
Executing failover method
failover: out of servers to try
Error getting file http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
[Errno 7] HTTP Error (CannotSendRequest):
[root@pc123 root]#


(2) /etc/resolv.conf でDNSサーバを無効にして、実行してみても、同じエラーが出た。

[root@pc123 root]# cat /etc/resolv.conf
search ****.net
#nameserver ***.***.***.***

[root@pc123 root]# yum install postfix
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
retrygrab() failed for:
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
Executing failover method
failover: out of servers to try
Error getting file http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
[Errno 7] HTTP Error (CannotSendRequest):
[root@pc123 root]#


/etc/yum.conf はインストール時より一切変更していません。
参考にしてください。
    • good
    • 0
この回答へのお礼

ありがとうございました。

結局、デフォルトゲートの設定が間違っていてアクセスできなかったみたいです。

設定を変更後、ちゃんとインストールできるようになりました。

/etc/yum.confに記載されているアドレスにブラウザからアクセスしたら画面が???って思いました(汗)

お礼日時:2006/08/21 14:34

VMware上にインストールしてあったFedora Core 1で実行してみたら以下の通り問題なくpostfixをインストール出来てます。



-------8<-------8<-------8<-------8<-------8<-------
# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=1

[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=http://fedora.redhat.com/releases/fedora-core-$r …

[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://fedora.redhat.com/updates/released/fedora …

#[updates-testing]
#name=Fedora Core $releasever - $basearch - Unreleased Updates
#baseurl=http://fedora.redhat.com/updates/testing/fedora- …

# yum -y install postfix
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Server: Fedora Core 1 - i386 - Released Updates
Finding updated packages
Downloading needed headers
getting /var/cache/yum/updates-released/headers/postfix-2-2.0.16-1.i386.hdr
postfix-2-2.0.16-1.i386.h 100% |=========================| 11 kB 00:00
Resolving dependencies
Dependencies resolved
I will do the following:
[install: postfix 2:2.0.16-1.i386]
Getting postfix-2.0.16-1.i386.rpm
postfix-2.0.16-1.i386.rpm 100% |=========================| 2.1 MB 00:11
Running test transaction:
Test transaction complete, Success!
postfix 100 % done 1/1
Installed: postfix 2:2.0.16-1.i386
Transaction(s) Complete
-------8<-------8<-------8<-------8<-------8<-------
    • good
    • 0
この回答へのお礼

ありがとうございます。

/etc/yum.confに記載されているアドレスにブラウザからアクセスしたら画面が???だったので
てっきり/etc/yum.confのアドレス間違いだと思ってしまいました(汗)

もう一度、ネットワークの設定を見直しましたらデフォルトゲートウェイの設定が間違ってました。

お礼日時:2006/08/21 14:38

このQ&Aに関連する人気のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!


人気Q&Aランキング