プロが教えるわが家の防犯対策術!

pip install scipy てしてたら、numpyをいっかいけされちゃって、1.26.1から1.22.4 にされちゃたんですけど大丈夫ですか?

A 回答 (2件)

> じゃあ、scipyはいらないとおもったばあい、scipy を消し下、 numpyをupgradeしればいいですか??



はい、scipyを使わないならそれで大丈夫です。

ライブラリのバージョンを気にしない場合は仮想環境を作る必要はないですが、ライブラリのバージョンが重要な場合、仮想環境の使用が推奨されます。
    • good
    • 0
この回答へのお礼

ありがとう

そなんですね。ありがとうございます(๑•̀ㅂ•́)و
やってみてわからなかったら、またべつに質問してみます。

お礼日時:2024/01/03 17:11

大丈夫の場合もあれば大丈夫じゃない場合もあります。



numpy1.26.1じゃないと動作しないプログラムがある場合はvenvなどの仮想環境を作ってnumpyをインストールし直すことで問題は回避できます。
    • good
    • 0
この回答へのお礼

じゃあ、scipyはいらないとおもったばあい、scipy を消し下、 numpyをupgradeしればいいですか??

お礼日時:2024/01/03 14:43

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人はこんなQ&Aも見ています


このQ&Aを見た人がよく見るQ&A