最新閲覧日:

USB接続している機器との接続が切れることがよくあります。切れるというのは、機器が認識されなくなってしまうという状態です。(この状態になると、USBからの電流も流れなくなります)
切れた場合、再度機器を認識させるには仕方なく再起動しています。
原因はわかっているんですが、CPUに対して高い負荷をかける作業を行っているとこのような現象になります。
USB接続はCPU負荷が結構かかるというので、高負荷の作業にタスクを取られて切断されてしまうってことかもしれませんが・・・。

この現象に対して何か対策出来ないものでしょうか。(パッチを当てるとか)

ちなみにOSはWin2kです。

このQ&Aに関連する人気のQ&A

A 回答 (7件)

BH6でWindows2000、うちと同じですね。


うちではコレガのUSB&VGA切り替え使ってキーボード・マウス・モニタをMacと切り替えながら使ってますが、全然平気ですね。
たまに結構無造作に抜いちゃったりしてますけど。
BIOSはRev1用のSSです。

さすがにADSLをUSBでとなると辛いんでしょうかね。ネットワークカードは1000円くらいで売ってますし、動作も軽くなると思います。
ADSLモデムをネットワーク型のものに変更できませんかね?

この回答への補足

BIOSはうちも同じですね。
モデムはすんなりと変更は出来ないようです…。
(基本料高めでルータ型があるのですけどね…)

補足日時:2001/05/06 00:39
    • good
    • 0

 BXチップセットでしたか。

しかも自分も使っていたBH6とは。
 では、チップセットメーカにUSBフィルタドライバの最新版があるかと思いますが、これを最新版にしても解決しないでしょうか。確かIntelではAGPsetという名前だったはずです。これにUSBドライバのアップデートも同梱されていますので、試しにアップグレードしてみましょう。ダウンロードは、Intelのwebサイトまで。直前までのリンクは
http://appsr.intel.com/scripts-df/Product_Filter …
です。ここより、チップセットの選択、次にOSを選択してダウンロードを続行しましょう。トップページは、下記URLよりどうぞ。

参考URL:http://www.intel.co.jp/

この回答への補足

いまさらですが、SP2をインストールしたら直ってしまいました。
皆さん、ありがとうございました。(01/06/09)

補足日時:2001/06/09 20:55
    • good
    • 0
この回答へのお礼

わざわざありがとうございます。
しかし、ドライバー(infinst_enu.zip)を落としてインストールしようとしましたが、"The current operating system supports the Intel chipset devices on your system. No INF update is needed."とメッセージが出て、インストール出来ないようでした。

お礼日時:2001/05/06 00:24

切断されたときにデバイスマネージャを開いてコンピュータ名を右クリック、「ハードウェア変更のスキャン」を実行してもUSBは復帰しないでしょうか。


ただ、この方法では根本的な解決にはならないのですけれど。

この回答への補足

この方法でも復帰しないようです。

補足日時:2001/05/06 00:18
    • good
    • 0

USBってホットプラグなので、動作中の抜き差しがOKなんですが、トラブった後で一度抜き差ししてみたらいかがでしょう?


これで治るようなら再起動よりもお手軽ですね。

この回答への補足

抜き差ししてもだめですね・・・。
他の機器を差しても認識すらしなくなるという状態です。

補足日時:2001/05/02 04:08
    • good
    • 0

 うちは同じくW2kで、ハブにXircomのPortStationを使い、デバイスにNEOSのスキャナを繋いでいますが、たまになりますね。

スキャナは電源が消灯し、HUBは電源供給をしているとPOWERランプはついていてもPortランプが消灯して、繋ぎなおすか電源を入れなおさないと復帰しなくなります。 
 一応、スキャナをPCに直接繋ぐと問題は起きなくなりました。もし問題を起こしやすいデバイスがわかっているのなら、繋ぐポートを替えてみるとよいのではないでしょうか。しかし同じハブの違うポートではだめみたいで、繋ぐ段を替えないとよくないみたいです。
 あと、嘘か真か、大体PC用のUSB機器はIntelのチップセットできちんと動くように設計されていると聞きますので、VIAなどの互換チップセットであればきちんとフィルタドライバをアップデートしておいたほうがよいでしょう。こちらはV1.08の最新版を使用しても依然改善されませんが。
    • good
    • 0
この回答へのお礼

普段はPCに直接機器を接続しています。HUBは現在使用していません。ポートは繋ぎ変えてもだめですね。
M/Bの方はBXチップセットです。(ABit BH6)

お礼日時:2001/05/02 00:11

負担がかかるってのはCPUだったんですね。


えっとUSB機器を相当つなげない限り大した
負担にはならないと思います。
こちらで体験した最悪環境
CPUがMMX200MHzのパソコンに
スキャナとプリンタをつなげて作業させてみましたが
何も問題ありませんでした。

多分なんですがWindows2000用のUSBドライバに
不具合があるのではないでしょうか?

ちなみにUSB機器は何でしょうか?
それがわかればもしかしたら何かわかるかもしれないです。

この回答への補足

USB機器はADSLモデムです。以前はTAがついていたんですが、その時もこの現象がおきています。
それ以外の機器は使用時しか接続していません。
CD-Rを焼いたり、動画の圧縮とかやっているとなります。

補足日時:2001/05/01 23:41
    • good
    • 0

USB機器に対する電流が足りないなら


電力供給型USBハブを導入すればいいと思います。

普通のハブに電源アダプタが付いているタイプを買えば
間違いないと思います。

この回答への補足

電力供給型USBハブは持っているのですが、以前電力供給して試してみましたがだめです。
また質問のような現象が起きるとUSBハブに電力を供給していても、ハブのランプが消えます。

補足日時:2001/05/01 05:15
    • good
    • 0

このQ&Aに関連する最新のQ&A

お探しのQ&Aが見つからない時は、教えて!gooで質問しましょう!

このQ&Aを見た人が検索しているワード


このカテゴリの人気Q&Aランキング

おすすめ情報

カテゴリ